GEEKKECH

Votre informaticien

Après la Mise à jour de WordPress 4.4, l’éditeur TinyMCE ne fonctionne plus

Il était temps, j’ai mis à jour www.safi-city.com, et l’éditeur TinyMCE ne finctionne plus

 Dans ce poste, j’ai partagé toutes les combines essayées, mais qui n’ont pas aboutit à une solution au problème. Faut savoir aussi qu’à l’instant même ou je publie le poste, je n’ai pas encore trouvé de solution au problème.

En faisant une recherche sur google, il s’est avéré que ce problème a été rencontré par d’autres webmasters en passant d’une version à une autre.

Au début, j’avais des doutes sur quelques extensions installées, WP Super Cach qui écrit dans des fichiers se trouvant sur wp-include ! Donc j’ai désactiver le plugin, le problème persiste.

Réaction suivante, désactiver tous les plugins, mais ca n’a pas réglé le problème.

Peut être ColorMag, donc, j’ai activé le thème  par défaut Twenty Sixteen, et rien n’a changé.

Je suis aller sur les différents forums, en quête d’indice, que dalles !!

J’ai téléchargé le WordPress 4.4, je l’ai décompressé …

J’ai lancé le client FTP FileZilla, me connecter au serveur, et supprimer le dossier TinyCME se trouvant au /wp-includes/js , et transférer depuis le dossier d’installation.

Mais, ca n’a pas marché !!!!
Bon, j’ai réinstallé encore une fois le WordPress 4.4 mais problème persiste.
A savoir qu’ emploi.safi-city.com fonctionne à merveille après la mise àjour, même configuration, même hébergeur (c’est un sous domaine, même version du PHP, et même paramètres de sécurité, le même thème et les mêmes plugins (ou presque) ) …
La version du PHP est 5.6, je l’ai mi à 5.3, et ca ne fonctionne toujours pas !!!

Queques tweets sur twitter !!! pas d’echo pour ma requête. 
J’ai une solution pour le moment : c’est en installant l’extension jetpack, je peux écrire mes articles depuis le site WordPress.com .  Mais avant d’écrire un article il faut désactiver le plugin iThemeSecurity (que je n’ai pas encore bien maitrisé et qui bloque l’accès à jetPack) et par la suite rendre mon site vulnérable pendant l’opération de saisie. Sans parler de la nécessite d’activer l’éditeur pour que les autres auteurs puissent rédiger des articles à leurs tour.
J’ai passé du coté de l’éditeur des CSS, en recherche d’indice, mais rien.
J’ai aussi, installer d’autres éditeurs, mais apparaments ils se basent tous sur l’API de TinyMCE.
J’ai essayé TinyMCE Advanced qui permet d’ajouter d’autres fonctionnaitées à ‘éditeur, mais on dirait qu’il hérite les fonctionnalités.

J’ai trouvé cette extension TinyMCE Config qui peut bien m’aider dans la résolution du problème mais ca nécessite une bonne compréhension de l‘API de TinyMCE

Mais vu que j’ai pas le temps, je vais installer le même plugin sur l’autre site et comparer les paramètres.
Je lance emploi.safi-city.com !! 
Et voilà, une autre surprise, Il me demande une mise à jour de la base de donnée !!!!
Je n ‘ai pas le choix, n’importe quel url mis en barre d’adresse me redirige vers la mise à jour de la base.
J’effectue la mise à jour, et j’ajoute un poste pour voir
Ca ne marche pas aussi sur le site de l’emploi.
Donc, je laisse tomber la comparaison  … le bricolage ne fonctionnera pas … Faut Agir comme programmeur Maintenant.
To be continued